top_fr
Se connecter

Important ! Problèmes possibles de connexion aux sites web, boutiques en ligne de Bitrix24 à partir du 30 septembre 2021

A partir du 30 septembre 2021 17:01 (UTC+3), les clients pourront rencontrer des problèmes avec une ancienne version de navigateurs ou de systèmes d'exploitation, ainsi que sur leurs propres serveurs ou hébergement :

  • lors de la connexion aux sites web et aux boutiques en lignes de Bitrix24 ;
  • lors de la connexion à Bitrix24 avec le service Propre domaine (plan Professional et plan archivé Professional) ;
  • lors de l'exécution de requêtes d'API REST de leur serveur à Bitrix24.

Cela est dû au fait que le certificat racine DST Root CA X3 a expiré, mais il est impliqué dans la chaîne de certificats clients que nous émettons à partir de Let's Encrypt et reste jusqu'en 2024 pour prendre en charge les appareils avec les versions Android 2.3.6-7.1.1.


Qu'est-ce qu'on peut faire ?

La seule solution correcte consiste à utiliser un logiciel actuel par les clients. En d'autres termes, mettez à jour vos appareils et navigateurs avec les dernières versions.

Si vous utilisez une machine virtuelle VMBitrix sur votre serveur, vous devez mettre à jour le package ca-certificates à l'aide de la commande :

yum update -y ca-certificates

Si vous utilisez un environnement serveur différent, veuillez contacter l'administrateur système de votre serveur.


Connexion aux sites web et comptes

Le problème ne concerne pas :

  • Windows >= XP SP3 (avec mises à jour automatiques)
  • macOS >= 10.12.1
  • iOS >= 10
  • Android >= 7.1.1
  • Mozilla Firefox >= 50.0
  • Ubuntu >= xenial/16.04 (avec mises à jour)
  • Debian >= jessie / 8 (avec mises à jour)
  • Java 8 >= 8u141
  • Java 7 >= 7u151
Les navigateurs Chrome, Safari, Edge, Opera, Vivaldi dépendront de la version du système d'exploitation sur lequel ils sont installés.

Dans tous les autres cas, il peut y avoir des problèmes de connexion, une erreur sera émise sur l'expiration des certificats lors de la connexion aux sites web, boutiques en ligne de Bitrix24 et aux comptes avec leur propre domaine.


Exécution de requêtes REST/API

Le problème affectera principalement les clients lors de l'exécution de requêtes API à partir de serveurs avec d'anciens logiciels qui utilisent :

  • openssl-1.0.1 - complètement incompatible et ne fonctionnera pas sans créer ses propres packages (CentOS 6).

  • openssl-1.0.2 - vous devez mettre à jour le package ca-certificates sur les serveurs (CentOS 7).

  • openssl-1.1.x - entièrement compatible.

Pour résoudre ce problème, contactez l'administrateur système de votre serveur.

Vous pouvez en savoir plus sur la compatibilité du certificat DST Root CA X3 avec les appareils et les systèmes d'exploitation dans la documentation Let's Encrypt.
Cela m'a aidé
Super :)
Optionnel :
Commentaires sur l'article
Cela ne m'a pas aidé
Nous sommes désolés :(
Pourriez-vous nous préciser pourquoi :
Commentaires sur l'article
J'ai encore des questions